Jump to content


Photo

Local area connection on Linux IGD


  • Please log in to reply
21 replies to this topic

#1 Ktulu1969

Ktulu1969

    New Member

  • Member
  • 6 posts

Posted 15 September 2004 - 04:33 PM

I dont know if this is the proper place to post this... but i will start here. I have dsl broadband, i connect through my local connection using my ethernet card. I was unable to connect yesterday so i checked the properties of my network connections and there was another local area connection labeled as an internet gateway titled "local area connection on Linux IGD". I called the phone company and they say it is not associated with them. I do know that it is associated with msn messanger.....but where did it come from...i did not install it, i dont have linux on my system. I only have one computer in my office so it is not needed for networking. Any information would be appreciated. TIA.

Ktulu

#2 Ktulu1969

Ktulu1969

    New Member

  • Member
  • 6 posts

Posted 15 September 2004 - 09:22 PM

I think i figured it out.

#3 Guest_Andreas_*

Guest_Andreas_*
  • Guests

Posted 20 September 2004 - 07:53 PM

I have the same problem after instelling a program. Maybe it was a trojan. Now I check my computer for viruses and trojans. Hopefully I will found something.
I reinstalled Windows but it didn't help (with new partition).
If I found a solution, then I post it here.

#4 Redhat

Redhat

    Mr. Marketing

  • Charter Members
  • 1,665 posts

Posted 20 September 2004 - 08:21 PM

QUOTE (Ktulu1969 @ Sep 15 2004, 10:22 PM)
I think i figured it out.

Would you mind posting your solution for us please :) ? Thanks :thumb:

#5 Hunter

Hunter

    The Flying Dutchman

  • General Admin
  • 12,477 posts

Posted 20 September 2004 - 08:24 PM

The "Local Area Connection on Linux IGD" "Type: Internet Gateway"
appears to have come from a Microsoft Windows Messenger Update. It
showed up originally about 04/16/04.
How to verify:
1. Launch Windows Messenger
2. Get online to you account and leave it active
3. Now got to Windows "START" button
4. Proceed to "Network Connections"
5. Right Click on LAN Connection Linux IGD and choose properties
6. There is one button in the lower right "Settings"
7. This opens "Advanced Settings"
8. You will see your IP address followed by a UDP and TCP port
9. Remove the checks from the boxes, save and restart.
10. Low and behold the "Local Area Connection on Linux IGD" is gone
with no problems.

This handled it on my system. PS:Qwest, Actiontec, my ISP had no clue.


http://groups.google...13.60&frame=off

#6 Hunter

Hunter

    The Flying Dutchman

  • General Admin
  • 12,477 posts

Posted 20 September 2004 - 08:27 PM

Also see these links for other background information. :)

http://groups.google...e.com&frame=off



Copyright © 2002 Linux UPnP Internet Gateway Device Project
* All rights reserved. *
* *
* This file is part of The Linux UPnP Internet Gateway Device (IGD).


http://www.fastflow....ate-0.91-cg.cpp




UPnP on your Linux 2.4 firewall how-to Knowledge base for linux and windows - Firewall

Note: we still haven't audio/video in MSN Messenger working, but we are very close. Input is welcome! Use the E-mail link (remove the spam words) or the webmaster form!


Some knowlegde about networking and Linux is required. We used WindowsXP and MSN Messenger beta-5, build 527, but it should also work with other Messenger versions. We're not sure if UPnP will work with other Windows versions (probably not, maybe there is an UPnP update available).

http://www.ruwebit.net/article/77

#7 Hunter

Hunter

    The Flying Dutchman

  • General Admin
  • 12,477 posts

Posted 20 September 2004 - 08:51 PM

If you ever do want to do some HomeNetworking with Windows XP, this article will help you.

How to troubleshoot home networking in Windows XP


http://support.micro...kb;en-us;308007

#8 Guest_Kevin Johnson_*

Guest_Kevin Johnson_*
  • Guests

Posted 09 October 2004 - 10:27 PM

This problem is actually due to a windows networking component. If you
remove the check from Internet Gateway found under the Windows Components
Network Services entry

( Click on Add Remove Programs in your control panel
Clickon Windows Components (Add or Remove)
Click on the details button by the Network Services
Remove check by Internet Gateway )

Your Linux LAn will be gone for good. This is something that is affected by Windows update and does involve Messenger software. It can and does mess
up broadband connectiivty.

#9 Guest_Internet tech dude (not from Que_*

Guest_Internet tech dude (not from Que_*
  • Guests

Posted 11 October 2004 - 09:25 PM

Well... If the quest tech support would have just done a simple google search when their customer called (like I did) they would have found there answer and fixed the problem for you.

Anyway. Thanks for the answer. I helped a confused customer with the info...

#10 pietra

pietra

    New Member

  • Member
  • 1 posts

Posted 13 October 2004 - 09:02 PM

:( Hi I also have the same Linux igd issue and I happen to be using a Qwest Actiontec also. Problem is I have NO CONTROL over this thing I can't delete it and if I try to disable it I end up with another message telling me that I can't alter the settings for it iether Help?

#11 grep

grep

    New Member

  • Member
  • 2 posts

Posted 20 September 2005 - 09:54 AM

I have the same problem, disabling 'internet device gateway discovery and control client' via add and remove windows compnents does indeed kill the connection. What i can't find out is why it was there in the first place and why it keeps coming back.

Having found it previously i used another method of killing it. Then i recently noticed it had returned on both of my computers - one needed to be reinstalled anyway so i went ahead and did it. No linux on IGD - days later no linux on IGD. How and why does this thing appear.

I do like many people have an actiontec router.

#12 iamnotyou

iamnotyou

    New Member

  • Member
  • 1 posts

Posted 01 October 2005 - 02:56 AM

I just found this on my PC and discovered it was a P2P port that was open. Closing the App took care of the problem. I suggest that you open it up and see what ports are open, then google the ports to see what they do.

QUOTE (Ktulu1969 @ Sep 15 2004, 04:33 PM)
I dont know if this is the proper place to post this... but i will start here.? I have dsl broadband, i connect through my local connection using my ethernet card.? I was unable to connect yesterday so i checked the properties of my network connections and there was another local area connection? labeled as an internet gateway titled "local area connection on Linux IGD".? I called the phone company and they say it is not associated with them.? I do know that it is associated with msn messanger.....but where did it come from...i did not install it, i dont have linux on my system.? I only have one computer in my office so it is not needed for networking.? Any information would be appreciated.? TIA.

Ktulu


#13 grep

grep

    New Member

  • Member
  • 2 posts

Posted 02 October 2005 - 11:01 AM

Been there and tried that! All the ports belong to my torrent client bit-tornado, the porblem is that the internet gateway is completely unnessacery - the client doesn't need the gateway and nor does it create it. What I really want to find out is how it got there in the first place.

#14 hEavyArmscUstom

hEavyArmscUstom

    New Member

  • Member
  • 1 posts

Posted 15 January 2006 - 06:42 AM

HI People I am from qwest tech support i do apologize for not supporting this issue because our calls are monitored and this is beyond our support boundaries but dont worry i am convincing my team to do an over support so that we could assist you better thanks

#15 KnowHow

KnowHow

    New Member

  • Member
  • 1 posts

Posted 18 March 2006 - 09:22 PM

Nothing is wrong, not a virus or trojan.
Just unplug the network cable, the connection will go off.

Edited by KnowHow, 18 March 2006 - 09:23 PM.