Jump to content


Photo

Local area connection on Linux IGD


  • Please log in to reply
21 replies to this topic

#16 Dr.P

Dr.P

    New Member

  • Member
  • 1 posts

Posted 06 April 2006 - 07:44 PM

What was the answer to this question about Local Area Connection on Linux IGD?

Thank you.

#17 warlock_01

warlock_01

    New Member

  • Member
  • 1 posts

Posted 09 April 2006 - 09:32 AM

Heads Up.

Linux IGD is a UPnP (universal plug and play) gateway service for LINUX and a Windows MAPI compliant technology that by-passes your default gateway. It usually shows under network connection after installing or uninstalling a router, wireless card, or even just re-inserting your Ethernet cables from your DSL modem or sometimes after installing or updating messaging services like MSN messenger, Yahoo Messenger, Remote Assistance, Remote Desktop etc... and usually shows up when your remote system is active. Linux IGD converts your default DNS servers and default gateway into something that it can use to be able to access a certain port in the ATM/PVC path to make a connection right away using a remote connection. but you can never wether your IP's and DNS had been changed even if you will going to check them under your Local Area Connection and IPCONFIG. The bad thing about this IGD is.. it runs automatically as soon as it detected an internet connection. Mostly Cable, ADSL, T1, T2, VDSL, xDSL and RADSL. As long as your internet connetion is alive it will continue running and sending packets to the ATM/PVC. Honestly I dont know what the hell IGD is sending to the ATM/PVC... one thing for sure.. IGD is using your internet connection for free and you are not aware of it.

Ex: If you are using an actiontec or a 2wire modem your default gateway is 192.168.0.1 and your subnet mask is 255.255.255.0, your Modems DHCP server should give you an IP address ranging from 192.168.0.2 to 99 and this is a valid IP address so you can connect to it. If you have a LINUX IGD in your LAN then all of your connection will be re-directed into something else. LINUX IGD gateway service will redirect your packets into something else, following the settings of your Router, Wireless Card, Messaging services Settings. In short... YOU CANNOT PING OUTSIDE THE MODEM. You can ping your modem OK but you cannot ping outside. Even though your DNS, GATEWAY, IP ADDRESSES are indeed correct.

Solution:

There are two ways to get rid of the LINUX IGD once and for all. I dont really recommend that you disable your UDP and TCP port in your LAN settings. Disabling these features will lead to winsock catalog corruption (for winxp sp2 users). We all know that if your catalog is corrupted then you may need to reset it first before you can load a webpage in your browser.

Steps :

First

By hard resetting your modem. If you are using an actiontec modem then you have to push the reset button at the back of your MODEM hold it for 20secs then unplug the power cord of the modem while pressing the reset... then quickly plug it in back again then release the press. Be sure that you know your connection type (PPPoA - PPPoE) and be sure that have your credentials are with you (PPP username and PPP password) so you can re-configure your actiontec again.

Second

By going to start > control panel > add/remove programs > add/remove windows component
Scroll down a little bit and high-light networking services then click DETAILS then uncheck the Internet Gateway (Linux IGD). It will be gone forever... finally you can stick your head now up to your ass and see if it fits.. breathe! its for free.


FYI

Do not call you ISP, Telephone Company or Modem Manufacturer about this one because even though they know how to disable it they will never support you on this because its totally out of their support boundaries so dont be proud if you tried to call them and tell you that they dont have single a clue about that freakin' IGD. (they will never tell you even if they do... dumbass!)

If you have additional questions about ADSL connection, Qwest, Actiontec Modems, 2wire 2700HG, Arescom 800, DSL 1000, MSN software and MSN accounts. Drop me a mail and we'll give it a shot - lorenzyyanapostol@hotmail.com

Edited by warlock_01, 09 April 2006 - 01:22 PM.


#18 abdo elrahman hegazy

abdo elrahman hegazy

    New Member

  • Member
  • 1 posts

Posted 19 February 2007 - 09:48 PM

hello all ,
actually i neeeed any one who heard about any solution for the problem of voice of msn over linux router
i need help in this topic

#19 Terryala

Terryala

    Board Grand Dad

  • Charter Members
  • 17,910 posts

Posted 21 February 2007 - 08:01 PM

HI abdo elrahman hegazy

Some information to pass on from one of our Staff members.

First if they use ip chains and a firewall.. check to see if you've explicitly told MSN Messenger in its preferences that it is behind a firewall


Then get the port info sorted out..

Windows and MSN Messenger Application

http://www.chebucto....le.html#WinMess



"basically they (Microsoft) say it won't work cause it opens your ports to comuter attack. If you want to do it. You have to let your firewall have access to the ports it works on. If you have a router, go to who makes it and find out how to open the ports on it. The firewalls and routers block these ports messenger voice works on. Good luck as I wouldn't open my computer ports to do this"

are these security problems really that threatening ....?
http://www.linuxforu...-messenger.html


How can I configure my firewall to access voice chat with MSN messenger 6.2?

http://lists.netfilt...ust/054994.html

Hello there,

Voice/video on MSN doesn't work behind firewall/nat. The negotiation of
the void/video connection is done in the payload of the packet.
Take a look at linux-igd:
http://linux-igd.sourceforge.net/
It's working for me.

Audio/Video support is currently under development in amns.

But if you want to try a tricky pluggin the following might help:

http://amsn.sourcefo... support status

I think that you must at least compile the linphone-im modules.

Good luck.

Hunter


http://www.freedownl...e-chat-msn.html

#20 Matthew G

Matthew G

    New Member

  • Member
  • 1 posts

Posted 02 November 2007 - 06:23 PM

Just trying to help out, if your router has an UPnP setting I found that by turning it on makes that connection appear and when off it goes away I have been trying too figure out how to allow my xboxlive connection run without interruption because of my NAT automatically switching from open, moderate, and strict this has interrupted my XboxLive connection the only way I can run the Live system is by opening my UPnP! I have tried to direct xboxlive ports to the adaptor but no luck, also tried to DMZ hosting same issue but if anyone could help me run XboxLive without my UPnP open plz help because I have to manually open to play XboxLive then close UPnP to shut off the extra traffic in my router.

#21 Bernielj77

Bernielj77

    New Member

  • Member
  • 2 posts

Posted 06 January 2009 - 01:52 AM

I see about 3 years of posts on this, so I don't know if I should even reply, but I'll say a few things here.

I could go on and on about the pros and cons of the "Local Area Connection on Linux IGD," and whether it's a "bug" or anything else, but I'll just give my opinions.

A few of them anyway...

For one thing, I don't believe it's a virus, or bug, or that there's even anything wrong here with this, and it's my opinion that this is just showing you that your ISP is using Linux for an operating system.

I may be wrong about that, and/or stupid, but I also believe that it's just showing you your Internet connection and I also believe that if you "get rid of it," that will prevent you from accessing the Internet...I believe that it's your Internet gateway.

If you don't want to see the above in your network connections, the "Local Area Connection on Linux IGD" that is, then the easiest way that I can think of, since there are multiple ways of "getting there from here" so to speak, of removing it, or so that you can't see it listed, is to click on "Start" to open the Start Menu, then move the cursor up to "Settings," if you're using the "Classic Start Menu," like I am in WIN-XP, then if you see "Network Connections" showing, then click on it to open the network connections, or if you have "Network Connections" set up to "expand," you'll see your network connections listed, but then instead of clicking on "Network Connections," right-click on "Network Connections," then click on "Open" to open your network connections.

Anyway the main thing is to open your "Network Connections."

You should see that "Local Area Connection on Linux IGD" is showing up as your "Internet Gateway."

There you'll also see something like: "LAN or High-Speed Internet" is showing something like: "Local Area Connection" for example.

There is sometimes showing a choice over to the left side of something like: "Hide icons for networked UPnP devices," but I'm not sure if that's in the "Network Connections," or just in the "Network Places," which I have an icon right on the Desktop for.

If it's turned off, then the message is reversed, something like "Show icons for networked UPnP devices."

I haven't enabled or disabled that for a long time so I'm not sure where you can turn that on and off, but I sometimes even check the box where it will show an icon down in the system tray when a connection is made to the Internet or Internet gateway.

You can check on the "Properties," and other things, by having these showing, including the ability to trouble-shoot a connection, or restart the connection, or "renew" the IP address, or enable and disable the connection, etc.

Anyway, that's about it, and that's my opinion, there's nothing wrong when the message shows up, especially if you're using any programs that require UPnP ports opened, like right now for example, I haven't seen the message for a long time, but when I installed SKYPE, the message showed up because SKYPE needs UPnP I guess, as I see it listed when I check on it.

If you're not using anything that uses UPnP, then you can close the UPnP ports, or disable UPnP in your router or DSL Cable-Modem, or DSL-Gateway, or wire-less router, etc...But if you use anything that requires UPnP, I think it's going to show up.

I'm not sure, but I think that you can set your system up to not show that message, but if it's "active," then it's there all the same.

I decided to say more than I originally was going to say after all, but I'll cut myself off now, and Have a Great Day,
Bernard

#22 Bernielj77

Bernielj77

    New Member

  • Member
  • 2 posts

Posted 06 January 2009 - 02:05 AM

As far as leaving the UPnP disabled when playing games, if you have a wire-less router like I have, there is a "settings panel" for "Gaming," where you can click on either a game or games that are listed there to play them, or yes, of course I see where one of you tried the DMZ, but I believe you need to sign up on some website in order for that to work, and I don't think that just enabling it will work for you, or you can use "Port Forwarding" with "Port Triggering" to play games, but don't ask me how to set those as I have never needed to do that.

Maybe I should try that however, because maybe the games that I do play via the Internet may play faster or better, but who knows.

I also have an Actiontec DSL Gateway for Internet accessing, and that has wire-less capability, but since that is only 54Mbps, and only has one, small, antenna, I don't use it wire-lessly, and instead, I use the Linksys Wireless router, which had two, smaller, antennas, for 100Mbps, full-duplex, but I had replaced them with 7Dbi Gain, fairly large, antennas for a better wireless signal.

I only use the wire-less router to play music, that I have saved on the hard drive, on the living room stereo going through a Roku Soundbridge I picked up at BestBuy.